FANDOM


A HSRP, a Hot Standby Router Protocol rövidítése.

Feladata hibatűrő routolt hálózat létrehozása több router felhasználásával. Egynél több router szükséges hozzá. Az egyik router kiesése esetén a tartalék router veszi át a forgalomirányítás szerepét. HSRP konfigurálásakor a fizikai routerek konfigurációja felett egy virtuális routert kell létrehozni.

HSRP paraméterekSzerkesztés

  • standby ip IP cím

Engedélyezi a HSRP-t. A megadott IP cím a virtuális router címe, amelyet a HSRP csoport minden tagjában definiálni kell. Opcionálisan meg lehet adni a HSRP csoport számát is, amely alapértelmezett értéke 0 (nulla). Pl:

C2600#Standby 12 ip 192.168.1.254
  • standby preempt: Megengedi, hogy az adott router aktív legyen, abban az esetben ha a prioritása nagyobb, mint a HSRP csoporton belül a többi routeré. Ha a parancsot nem adjuk ki, akkor a router nem lehet aktív a HSRP csoportban. Opcionálisan a csoport száma is megadható:
C2600#standby 12 preempt
  • standby priority prioritási szint: Az adott router prioritását adja meg. Az alapértelmezett szint 100. A csoporton belül a legnagyobb prioritású lesz az aktív router. Ha routernek nagyobb prioritást adunk, akkor nagyobb eséllyel lesz az adott router aktív. Opcionálisan a HSRP csoport száma is megadható.
C2600#standby 12  priority 130
  • standby authentication szöveg: Konfigurációs parancs, amelyben egy 8 karakteres szöveg megadható. Ez a szöveg belekerül a HSRP multicast csomagokba. Nem kötelező alkalmazni. Amennyiben használjuk, akkor a csoport minden tagjában alkalmazni kell, mert a csoport tagjai ezen szöveg alapján hitelesítik a csomagot. Opcionálisan a HSRP csoport száma is megadható.
C2600#standby authentication szoveg
  • standby timers hello time hold time: konfigurációs parancs a HSRP belső időzítések idejének módosítására. Az értékek másodpercben értendőek. A router rendszeres időközönként (hello time) életjelet küld a hálózaton, amely időközöket az első paraméterben adhatunk meg. Alapértelmezett értéke 3 másodperc. A második paraméterben adható meg, hogy a router meddig várjon az életjelre. Alapértelmezett értéke 10 másodperc. A várakozási idő leteltével amennyiben a router nem kapott életjelet, a router az aktív routert nem működőnek tekinti. A standby timers parancsot ha megadjuk, akkor a HSRP csoporton belül a hello time és a hold time paramétereket egységesen kell beállítani. Opcionálisan a HSRP csoport száma is megadható.
C2600#standby 1 timers 6 18

HSRP konfigurálásaSzerkesztés

1. példa: Alap HSRP konfigurációSzerkesztés

Hsrp01

Router_A konfigurációjaSzerkesztés

hostname Router_A
...
interface FastEthernet 0/0
ip address 192.168.1.252 255.255.255.0
standby ip 192.168.1.254               ! HSRP virtuális router cím
standby preempt                        ! Aktív routerként engedélyezve
standby priority 110                   ! Default aktív routerként kiválasztva
!
interface FastEthernet 0/1
ip address 195.1.1.254 255.255.255.0
...
router eigrp 44
network 192.168.1.0
network 195.1.1.0
...

Router_B konfigurációjaSzerkesztés

hostname Router_B
...
interface FastEthernet 0/0
ip address 192.168.1.253 255.255.255.0
standby ip 192.168.1.254               ! HSRP virtuális router cím
standby preempt                        ! Aktív routerként engedélyezve
!
interface FastEthernet 0/1
ip address 195.1.2.254 255.255.255.0
...
router eigrp 44
network 192.168.1.0
network 195.1.2.0
...

PC konfigurációjaSzerkesztés

IP-cím. . . . . . . . . . . : 192.168.1.100
Alhálózati maszk. . . . . . : 255.255.255.0
Alapértelmezett átjáró. . . : 192.168.1.254

A példában a Router_A az alapértelmezett router, mivel a prioritása 110, és ez nagyobb mint a Router_B esetében. A router_B prioritása nem dekralált, igy az alapértelmezett 100-as értéket kapja meg. A PC konfigurációja függetlenné válik a routerek állapotától. Az alapértelmezett átjáró a virtuális router címére mutat.

2. példa: HSRP konfiguráció terhelésmegosztássalSzerkesztés

Hsrp02

Router_A konfigurációja:Szerkesztés

interface FastEthernet 0/0
ip address 192.168.1.251 255.255.255.0
standby 4 ip 192.168.1.254 
standby 4 priority 110
standby 4 preempt
standby 5 ip 192.168.1.253
standby 5 preempt
…

Router_B konfigurációja:Szerkesztés

interface FastEthernet 0/0
ip address 192.168.1.252 255.255.255.0
standby 4 ip 192.168.1.254 
standby 4 preempt
standby 5 ip 192.168.1.253
standby 5 priority 110
standby 5 preempt
…

PC_A konfigurációjaSzerkesztés

IP-cím. . . . . . . . . . . : 192.168.1.100
Alhálózati maszk. . . . . . : 255.255.255.0
Alapértelmezett átjáró. . . : 192.168.1.253

PC_B konfigurációjaSzerkesztés

IP-cím. . . . . . . . . . . : 192.168.1.101
Alhálózati maszk. . . . . . : 255.255.255.0
Alapértelmezett átjáró. . . : 192.168.1.253

A példában két HSRP csoport van. A 4-es csoport aktív tagja a Router_A és a meleg tartalék a Router_B. Az 5-ös csoportban viszont a Router_B aktív, a Router_A a melegtartalék. A Router_A kiesése esetén a 4-es csoportban a Router_B átveszi az aktív router szerepét, az 5-ös csoportban a szerepe nem változik, akív marad ott is. A Router_B kiesése esetén a 4-es csoportban a Router_A marad, és az 5-ös csoportban válik aktívvá. A hiba elmúlta esetén a routerek ismét az alapértelmezett szerepüket veszik vissza. A hibátlan működéshez a routerek konfigurálásakor minden csoportban ki kell adni a standby preempt parancsot. A PC-k terhelés megosztás alapu konfigurálásakor a gépek egyik felét az egyik viruális, a másik felét a másik virtuális routerhez kell konfigurálni.